I made the leap on bought a Yamakasi Catleap yesterday. I verified it was working properly with my 13" MBP and a HDMI to DVI-D connector. Image quality was great no dead pixels.

I brought it home, using the same cable and plugged it into my desktop Win 10 computer. No image showed up on the monitor. I tried again using a DVI to DVI cable and this happened: https://imgur.com/gallery/aGFo2

1. What type of GPU do you have installed?
GTX 1050 Ti
2. Current drivers installed (clean install was attempted)?
The problem occurred prior to any driver installation. I could not get any of the NVIDIA OC drivers to install (even with test mode enabled) so searching the forums I found a driver that "Toasty" uploaded that other people seemed to have success with and installed that. But it didn't change my odd 4 screens in 1 issue.
3. Tried different DVI cable - either new or from a known working monitor?
The HDMI to DVI-D cable works perfectly with my 13" MBP, however an image won't even show up when I use it with my 1050 Ti.
4. Unplugged all other monitors and tried just plugging Catleap in BOTH outputs on your GPU?
Tried this, no changes.

Any thoughts or suggestions are appreciated!